Repository navigation
Upgrade LiteLLM to fix CVE-2026-114612 - #129
Merged
Merged
Conversation
Raise the LiteLLM floor to 1.104.0 and lock 1.108.0. CVE-2026-114612 (CVSS 9.9) lets an internal user of a LiteLLM proxy forge a proxy-admin token. It affects 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1 and 1.104.0-rc.2. Compass uses the LiteLLM SDK, not the proxy server, but the locked 1.98.0 is in the affected range and scanners flag it. LiteLLM 1.108.0 requires boto3>=1.43.117, so boto3 and botocore move to 1.43.124, and httpx[http2] adds h2, hpack and hyperframe. OSV-Scanner reports no license for the new boto3, botocore and hyperframe releases, so they get overrides matching their PyPI metadata (Apache-2.0, Apache-2.0, MIT). Disclosures are regenerated with make update-licenses.
BrianNewsom
approved these changes
Nov 4, 2026
nicot
marked this pull request as ready for review
November 4, 2026 22:01
LiteLLM 1.108 types embedding() as EmbeddingResponse | Coroutine, since it returns a coroutine when aembedding=True. Check the type so ty accepts the synchronous call's return value.
tests/test_merge.py imports helpers as tests.test_trace_contract. That only worked because importing LiteLLM 1.98 added the working directory to sys.path; LiteLLM 1.108 does not, so collection failed under plain pytest.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Why
CVE-2026-114612 (CVSS 9.9): an internal user of a LiteLLM proxy can forge a proxy-admin token and run commands through the MCP stdio endpoint. It affects 1.87.0 until 1.100.4 / 1.101.3 / 1.102.2 / 1.103.1 / 1.104.0-rc.2. Compass only uses the LiteLLM SDK, not the proxy server, so this isn't exploitable through Compass, but the locked 1.98.0 is in the affected range and scanners flag it.
Changes
pyproject.toml:litellm>=1.55,<2→litellm>=1.104.0,<2. Every final release from 1.104.0 on includes the fix; a floor of 1.100.4 would still allow vulnerable 1.101.0–1.101.2.uv.lock:uv lock --upgrade-package litellm→ litellm 1.108.0. It requiresboto3>=1.43.117, so boto3/botocore go to 1.43.124 and certifi to 2026.10.23.httpx[http2]adds h2, hpack and hyperframe.third_party/license_overrides.yaml: OSV-Scanner reports no license for the new boto3, botocore and hyperframe releases. Added overrides matching their PyPI metadata: boto3 and botocore areApache-2.0, hyperframe is MIT (its classifier isLicense :: OSI Approved :: MIT License).THIRD_PARTY_LICENSES.md,third_party/licenses.jsonlandthird_party/NOTICES.txtwithmake update-licenses(OSV-Scanner v2.3.3, the CI version).Testing
make check-licenses,tools/check_copyright_headers.py,ruff check,ruff format --checkpytest: 941 passedNote: #124 also changes
uv.lockand the license disclosures, so whichever PR merges second will needuv lockandmake update-licensesrerun.